Bettel Networking Issues

Incident Report for Kazehana Networks

Resolved

Things seem to have resolved.
Posted Mar 19, 2026 - 13:26 EDT

Investigating

We are now investigating a separate issue with the same provider that is impacting Bettel’s IPv6 connectivity. As our primary MX is working, this is not impacting mail flow.
Posted Mar 19, 2026 - 08:15 EDT
This incident affected: Hosts/PoPs (Bettel - Spokane, WA).