High Load on Anycast Nodes

Incident Report for Kazehana Networks

Resolved

This incident has been resolved.
Posted Jan 28, 2026 - 22:50 EST

Monitoring

We've completed the restarts and all nodes are looking normal. We will monitor a bit for stability.
Posted Jan 28, 2026 - 20:05 EST

Update

This appears to be a known issue with systemd in high route environments. Restarting the nodes appears to have resolved the problem, and we are going to slowly complete this with the other nodes. We will keep an eye out for reoccurrences and consider other avenues to resolve the problem if it continues to show up.
Posted Jan 28, 2026 - 19:53 EST

Identified

We are working on an issue with 3 of the 4 anycast nodes which is resulting in high CPU load. This does not appear to be affecting traffic flow at this time, but it is making the machines slow when running commands. We have identified that systemd-resolved is chewing up CPU on these machines, which started roughly within the same hour, but we are unclear as to why at this time.

We have seen this problem before, but limited to single sites. We are working to resolve the issue without disrupting service, but we may need to temporarily withdraw prefixes as needed to restart services and/or the nodes themselves.
Posted Jan 28, 2026 - 19:41 EST
This incident affected: Kazehana Services (Windflower CDN Anycast) and Hosts/PoPs (Sakayanagi - Chicago, IL, Karuizawa - Kansas City, MO, Kushida - London, UK).